免费邀请码更改用户名CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
搜索
查看: 58|回复: 1
收起左侧

易语言置入代码实现整数型位同或运算(先进行位异或计算+再将结果按位取反计算并返回)

[复制链接]
发表于 2019-6-20 11:02:24 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x


  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  8. 输出调试文本 (位同或 (123, 456))
  9. 输出调试文本 (位同或 (1234567, 2345678))
  10. 输出调试文本 (位取反 (位异或 (1234567, 2345678)))




  11. .子程序 位同或, 整数型, 公开, 如两个数值对应比特位的值不相等,则返回值的对应位就为0,否则为1。返回计算后的结果。
  12. .参数 位运算数值一, 整数型
  13. .参数 位运算数值二, 整数型

  14. 置入代码 ({ 139, 69, 8, 51, 69, 12, 247, 208, 201, 194, 8, 0 })
  15. ' mov eax,[ebp+8]
  16. ' xor eax,[ebp+12]
  17. ' not eax
  18. ' leave
  19. ' retn 8
  20. 返回 (0)



复制代码

相关帖子

回复

使用道具 举报

腾讯云数据库性能卓越稳定可靠,为您解决数据库运维难题
您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

小黑屋|手机版|Archiver|官方QQ群|从F到0 ( 蒙ICP备17002595号-1 )
蒙公网安备 15010402000325号 腾讯云安全认证

GMT+8, 2019-9-20 00:59, 100.26.182.28 , Processed in 0.747004 second(s), 30 queries .

Powered by Discuz! X3.4 © 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表