免费邀请码更改用户名CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
搜索
查看: 34|回复: 2
收起左侧

易语言汇编置入代码实现极速计算求出一个整数型数组的逆序数值 (返回整数型)

[复制链接]
发表于 2019-7-5 15:00:42 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码

  5. 置随机数种子 ()
  6. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  7. 返回 (0)  ' 可以根据您的需要返回任意数值

  8. .子程序 _临时子程序
  9. .局部变量 整数数组, 整数型, , "0"
  10. .局部变量 计数, 整数型

  11. .变量循环首 (0, 256, 1, 计数)
  12.     加入成员 (整数数组, 计数)
  13.     整数型_数组洗牌 (整数数组)
  14.     ' 数组排序 (整数数组, 假)
  15.     调试输出 (整数数组, 求逆序数 (整数数组))

  16. .变量循环尾 ()





  17. .子程序 求逆序数_易源码, 整数型
  18. .参数 数, 整数型, 数组
  19. .局部变量 ebx, 整数型
  20. .局部变量 ecx, 整数型
  21. .局部变量 eax, 整数型
  22. .局部变量 edx, 整数型
  23. .局部变量 esi, 整数型

  24. esi = 取数组成员数 (数)
  25. .计次循环首 (esi, ebx)
  26.     edx = 数 [ebx]
  27.     .变量循环首 (ebx + 1, esi, 1, ecx)
  28.         .如果真 (数 [ecx] < edx)
  29.             eax = eax + 1
  30.         .如果真结束

  31.     .变量循环尾 ()
  32. .计次循环尾 ()
  33. 返回 (eax)


  34. .子程序 求逆序数_汇编, 整数型, 公开
  35. .参数 数, 整数型, 数组

  36. 置入代码 ({ 83, 81, 82, 86, 87, 139, 117, 8, 139, 62, 139, 119, 4, 184, 0, 0, 0, 0, 187, 0, 0, 0, 0, 131, 199, 8, 235, 19, 139, 20, 159, 67, 139, 203, 235, 7, 57, 20, 143, 115, 1, 64, 65, 59, 206, 114, 245, 59, 222, 114, 233, 95, 94, 90, 89, 91, 201, 194, 4, 0 })
  37. ' push ebx
  38. ' push ecx
  39. ' push edx
  40. ' push esi
  41. ' push edi
  42. ' mov esi,[ebp+8]
  43. ' mov edi,[esi]
  44. ' mov esi,[edi+4]
  45. ' mov eax,0
  46. ' mov ebx,0
  47. ' add edi,8
  48. ' .while ebx < esi
  49. ' mov edx,[edi+ebx*4]
  50. ' inc ebx
  51. ' mov ecx,ebx
  52. ' .while ecx < esi
  53. ' .if [edi+ecx*4] < edx
  54. ' inc eax
  55. ' .endif
  56. ' inc ecx
  57. ' .endw
  58. ' .endw
  59. ' pop edi
  60. ' pop esi
  61. ' pop edx
  62. ' pop ecx
  63. ' pop ebx
  64. ' leave
  65. ' retn 4

  66. 返回 (0)

  67. .子程序 求逆序数, 整数型
  68. .参数 数, 整数型, 数组
  69. .局部变量 易源码, 整数型
  70. .局部变量 汇编, 整数型

  71. 易源码 = 求逆序数_易源码 (数)
  72. 汇编 = 求逆序数_汇编 (数)
  73. 检查 (易源码 = 汇编)
  74. 返回 (汇编)

  75. .子程序 整数型_数组洗牌
  76. .参数 数组, 整数型, 参考 数组
  77. .局部变量 下标, 整数型
  78. .局部变量 数组2, 整数型, , "0"

  79. .判断循环首 (取数组成员数 (数组) ≠ 0)
  80.     下标 = 取随机整数 (1, 取数组成员数 (数组))
  81.     加入成员 (数组2, 数组 [下标])
  82.     删除成员 (数组, 下标, 1)
  83. .判断循环尾 ()
  84. 数组 = 数组2

  85. .子程序 限制整数范围, 整数型
  86. .参数 数值, 整数型
  87. .参数 最大值, 整数型
  88. .参数 最小值, 整数型
  89. .局部变量 无符号数值, 长整数型
  90. .局部变量 无符号最大值, 长整数型
  91. .局部变量 无符号最小值, 长整数型
  92. .局部变量 无符号答案, 长整数型

  93. .如果真 (最大值 < 最小值)
  94.     交换变量 (最大值, 最小值)
  95. .如果真结束
  96. 无符号数值 = 数值 + 2147483648
  97. 无符号最大值 = 最大值 + 2147483648
  98. 无符号最小值 = 最小值 + 2147483648
  99. 无符号答案 = 无符号数值 % (无符号最大值 - 无符号最小值 + 1) + 无符号最小值
  100. 返回 (无符号答案 - 2147483648)

  101. .子程序 取随机整数, 整数型, , 取随机整数 范围 -2147483648~2147483647
  102. .参数 最大值, 整数型, , 支持负数
  103. .参数 最小值, 整数型
  104. .局部变量 字节集, 字节集
  105. .局部变量 计数, 整数型
  106. .局部变量 整数, 整数型

  107. 字节集 = 取空白字节集 (4)
  108. .计次循环首 (4, 计数)
  109.     字节集 [计数] = 取随机数 (, )
  110. .计次循环尾 ()
  111. 返回 (限制整数范围 (取字节集数据 (字节集, #整数型, 1), 最大值, 最小值))

复制代码

相关帖子

回复

使用道具 举报

腾讯云为数百万企业和开发者提供安全、稳定的云服务器、云数据库、CDN等云服务
您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

小黑屋|手机版|Archiver|官方QQ群|从F到0 ( 蒙ICP备17002595号-1 )
蒙公网安备 15010402000325号 腾讯云安全认证

GMT+8, 2019-7-17 00:34, 107.23.37.199 , Processed in 0.080081 second(s), 29 queries .

Powered by Discuz! X3.4 © 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表