更改用户名CRC32解密回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
查看: 124|回复: 1
收起左侧

易语言置入代码指定两个不同内存地址指针,检测数据连续多少字节一致 (返回整数型)

[复制链接]
发表于 2019-7-15 08:32:24 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册有礼

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 A, 字节集
  9. .局部变量 B, 字节集
  10. .局部变量 C, 文本型
  11. .局部变量 D, 文本型

  12. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  13. A = { 1, 2, 3, 4, 5, 6, 7, 8, 9 }
  14. B = { 1, 2, 3, 4, 5, 6, 7, 8, 10 }
  15. 输出调试文本 (取连续一致字节数 (取变量数据地址 (A), 取变量数据地址 (B)))
  16. C = “Hello World!中文测试123”
  17. D = “Hello World!中文测试234”
  18. 输出调试文本 (取连续一致字节数 (取变量数据地址 (C), 取变量数据地址 (D)))



  19. .子程序 取连续一致字节数, 整数型, 公开, 用于检测两个指针连续多少字节一致 (会一直累加、无限扫描下去直到内存字节不等于为止,访问非法地址会出错)
  20. .参数 指针A, 整数型
  21. .参数 指针B, 整数型

  22. 置入代码 ({ 83, 81, 82, 51, 192, 139, 77, 8, 139, 85, 12, 138, 25, 58, 26, 116, 2, 235, 5, 64, 65, 66, 235, 243, 90, 89, 91, 201, 194, 8, 0 })
  23. ' push ebx
  24. ' push ecx
  25. ' push edx
  26. ' xor eax,eax
  27. ' mov ecx,[ebp+8]
  28. ' mov edx,[ebp+12]
  29. ' ASM_LOOP:
  30. ' mov bl,[ecx]
  31. ' .if bl != [edx]
  32. ' jmp ASM_END
  33. ' .endif
  34. ' inc eax
  35. ' inc ecx
  36. ' inc edx
  37. ' jmp ASM_LOOP
  38. ' ASM_END:
  39. ' pop edx
  40. ' pop ecx
  41. ' pop ebx
  42. ' leave
  43. ' retn 8

  44. 返回 (0)
复制代码

相关帖子

回复

使用道具 举报

腾讯云服务器安全可靠高性能,多种配置供您选择
您需要登录后才可以回帖 登录 | 注册有礼

本版积分规则