设为首页收藏本站帮助中心
查看: 18|回复: 0
收起左侧

易语言实现判断 计次循环首、变量循环首 循环语句执行是否正确 (返回逻辑型)

[复制链接]
发表于 4 天前 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码

  4. .如果 (计次循环首_变量循环首_是否执行正确 () = 假)
  5.     信息框 (“计次循环首 或 变量循环首 执行存在错误,请尝试重启计算机或重装易语言。”, 0, , )
  6. .否则
  7.     输出调试文本 (“正确”)
  8. .如果结束

  9. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  10. 返回 (0)  ' 可以根据您的需要返回任意数值

  11. .子程序 _临时子程序



  12. .子程序 计次循环首_变量循环首_是否执行正确, 逻辑型, 公开, 检测核心库的 计次循环首() 、变量循环首() 循环是否执行正确,返回假请尝试重启计算机,请勿执行任何易语言程序
  13. .局部变量 计数, 整数型
  14. .局部变量 计数2, 整数型

  15. .计次循环首 (10, 计数)
  16.     计数2 = 计数2 + 1
  17.     .如果真 (计数2 ≠ 计数)
  18.         返回 (假)
  19.     .如果真结束

  20. .计次循环尾 ()
  21. .如果真 (计数 ≠ 11)
  22.     返回 (假)
  23. .如果真结束
  24. 计数2 = 0
  25. .变量循环首 (1, 10, 1, 计数)
  26.     计数2 = 计数2 + 1
  27.     .如果真 (计数2 ≠ 计数)
  28.         返回 (假)
  29.     .如果真结束

  30. .变量循环尾 ()
  31. 返回 (计数 = 11)

复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则