设为首页收藏本站帮助中心
查看: 50|回复: 0
收起左侧

易语言 寻找文本() 和 寻找字节集() 的工作原理、查找结果、返回值不同,千万不要混用

[复制链接]
发表于 2020-12-27 20:15:30 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序
  7. .局部变量 文本, 文本型
  8. .局部变量 被搜寻, 文本型
  9. .局部变量 欲寻找, 文本型

  10. 被搜寻 = “测试”
  11. 欲寻找 = “馐”
  12. 文本 = “被搜寻:” + 被搜寻 + “ 欲寻找:” + 欲寻找 + #换行符
  13. 文本 = 文本 + “寻找文本 返回值:” + 到文本 (寻找文本 (被搜寻, 欲寻找, , 真)) + #换行符
  14. 文本 = 文本 + “寻找字节集 返回值:” + 到文本 (寻找字节集 (到字节集 (被搜寻), 到字节集 (欲寻找), )) + #换行符
  15. 信息框 (文本, 0, , )
复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则