设为首页收藏本站帮助中心
查看: 384|回复: 0
收起左侧

易语言实现不区分大小写分割文本型字符串到数组的方法

[复制链接]
发表于 2020-1-11 14:35:01 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 文本型数组, 文本型, , "0"

  9. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  10. 分割文本_不分大小写 (“1A2a3A4aBa5”, “a”, , 文本型数组)
  11. 调试输出 (文本型数组)

  12. 调试输出 (分割文本 (“1A2a3A4aBa5”, “a”, ))


  13. .子程序 分割文本_不分大小写
  14. .参数 待分割文本, 文本型
  15. .参数 用作分割的文本, 文本型
  16. .参数 要返回的子文本数目, 整数型, 可空
  17. .参数 返回值数组, 文本型, 参考 数组

  18. 用作分割的文本 = 到小写 (用作分割的文本)

  19. 待分割文本 = 子文本替换 (待分割文本, 用作分割的文本, 用作分割的文本, , , 假)
  20. .如果 (是否为空 (要返回的子文本数目))
  21.     返回值数组 = 分割文本 (待分割文本, 用作分割的文本, )
  22. .否则
  23.     返回值数组 = 分割文本 (待分割文本, 用作分割的文本, 要返回的子文本数目)
  24. .如果结束

复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则