设为首页收藏本站帮助中心
查看: 734|回复: 0
收起左侧

易语言温度单位换算:摄氏度与华氏度、开氏度、兰氏度、列氏度转换 (返回双精度小数型)

[复制链接]
发表于 2021-3-30 10:25:25 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png
  1. .版本 2

  2. .程序集 程序集1, , , 非摄氏度转换 比如:华氏度到开氏度 等 需要转换成摄氏度再转换过去

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. 输出调试文本 (摄氏度到华氏度 (100))
  8. 输出调试文本 (华氏度到摄氏度 (100))
  9. 输出调试文本 (摄氏度到开氏度 (100))
  10. 输出调试文本 (开氏度到摄氏度 (100))
  11. 输出调试文本 (摄氏度到兰氏度 (100))
  12. 输出调试文本 (兰氏度到摄氏度 (100))
  13. 输出调试文本 (摄氏度到列氏度 (100))
  14. 输出调试文本 (列氏度到摄氏度 (100))


  15. .子程序 摄氏度到华氏度, 双精度小数型, 公开
  16. .参数 摄氏度, 双精度小数型

  17. 返回 (32 + 摄氏度 × 1.8)

  18. .子程序 华氏度到摄氏度, 双精度小数型, 公开
  19. .参数 华氏度, 双精度小数型

  20. 返回 ((华氏度 - 32) ÷ 1.8)

  21. .子程序 摄氏度到开氏度, 双精度小数型, 公开
  22. .参数 摄氏度, 双精度小数型

  23. 返回 (摄氏度 + 273.15)

  24. .子程序 开氏度到摄氏度, 双精度小数型, 公开
  25. .参数 开氏度, 双精度小数型

  26. 返回 (开氏度 - 273.15)

  27. .子程序 摄氏度到兰氏度, 双精度小数型, 公开
  28. .参数 摄氏度, 双精度小数型

  29. 返回 ((摄氏度 + 273.15) × 1.8)

  30. .子程序 兰氏度到摄氏度, 双精度小数型, 公开
  31. .参数 兰氏度, 双精度小数型

  32. 返回 (兰氏度 ÷ 1.8 - 273.15)

  33. .子程序 摄氏度到列氏度, 双精度小数型, 公开
  34. .参数 摄氏度, 双精度小数型

  35. 返回 (摄氏度 ÷ 1.25)

  36. .子程序 列氏度到摄氏度, 双精度小数型, 公开
  37. .参数 列氏度, 双精度小数型

  38. 返回 (列氏度 × 1.25)
复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则