免费邀请码更改用户名CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
搜索
查看: 355|回复: 3
收起左侧

易语言不到半秒时间快速生成1~10000不重复随机数并存放于数组的实现方法

[复制链接]
发表于 2018-5-6 15:30:15 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码

  5. 置随机数种子 ()
  6. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  7. 返回 (0)  ' 可以根据您的需要返回任意数值

  8. .子程序 _临时子程序
  9. .局部变量 时间, 整数型
  10. .局部变量 数组, 整数型, , "0"

  11. 时间 = 取启动时间 ()

  12. 取不重复随机数 (10000, 数组)

  13. 调试输出 (取启动时间 () - 时间)
  14. 调试输出 (数组)

  15. .子程序 取不重复随机数, 逻辑型, , 生成一定数量的随机数数组
  16. .参数 数量, 整数型, , 范围1~32767
  17. .参数 数组, 整数型, 数组, 存放生成结果
  18. .局部变量 计数, 整数型
  19. .局部变量 数值, 整数型
  20. .局部变量 位置, 整数型
  21. .局部变量 方法, 整数型

  22. .如果真 (数量 < 1 或 数量 > 32767)
  23.     返回 (假)
  24. .如果真结束
  25. 重定义数组 (数组, 假, 数量)
  26. .计次循环首 (数量, 计数)
  27.     数组 [计数] = 计数
  28. .计次循环尾 ()
  29. .计次循环首 (数量, 计数)
  30.     位置 = 取随机数 (1, 数量)
  31.     数值 = 数组 [位置]
  32.     删除成员 (数组, 位置, 1)
  33.     加入成员 (数组, 数值)
  34.     交换变量 (数组 [计数], 数组 [取随机数 (1, 数量)])
  35.     交换变量 (数组 [取随机数 (1, 数量)], 数组 [取随机数 (1, 数量)])
  36. .计次循环尾 ()
  37. 返回 (真)
复制代码


相关帖子

回复

使用道具 举报

腾讯云数据库性能卓越稳定可靠,为您解决数据库运维难题
发表于 2018-5-6 18:58:58 | 显示全部楼层
这个方法绝了,把中间的删了放到后面,然后再交换。
回复 支持 反对

使用道具 举报

发表于 2018-5-6 19:49:00 | 显示全部楼层
同楼上,占个板凳。
回复 支持 反对

使用道具 举报

发表于 2018-5-7 11:18:58 | 显示全部楼层
地板也是我的呢
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

小黑屋|手机版|Archiver|官方QQ群|从F到0 ( 蒙ICP备17002595号-1 )
蒙公网安备 15010402000325号 腾讯云安全认证

GMT+8, 2019-8-25 14:50, 34.236.190.216 , Processed in 0.093750 second(s), 29 queries .

Powered by Discuz! X3.4 © 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表