免费邀请码更改用户名CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
搜索
查看: 198|回复: 2
收起左侧

易语言实现日期时间型与整数型的时间戳的互相转换的实现方法易模块源码。

[复制链接]
发表于 2017-10-13 10:30:56 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png


  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 今天, 日期时间型
  9. .局部变量 今天时间戳, 整数型

  10. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  11. 今天 = 取现行时间 ()
  12. 今天时间戳 = 日期时间到时间戳 (今天)
  13. 调试输出 (今天, 今天时间戳, 时间戳到日期时间 (今天时间戳))

  14. .子程序 日期时间到时间戳, 整数型, 公开
  15. .参数 时间, 日期时间型

  16. 返回 (取时间间隔 (时间, [1970年1月1日8时], 8))


  17. .子程序 时间戳到日期时间, 日期时间型, 公开
  18. .参数 时间戳, 整数型

  19. 返回 (增减时间 ([1970年1月1日8时], 8, 时间戳))


复制代码




相关帖子

回复

使用道具 举报

腾讯云数据库性能卓越稳定可靠,为您解决数据库运维难题
发表于 2017-10-13 16:27:31 | 显示全部楼层
原来时间戳就这玩意呀!长见识了呢。
回复 支持 反对

使用道具 举报

发表于 2017-10-15 21:42:11 | 显示全部楼层
不想长大 发表于 2017-10-13 16:27
原来时间戳就这玩意呀!长见识了呢。

当然就这样转换的了。

回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

小黑屋|手机版|Archiver|官方QQ群|从F到0 ( 蒙ICP备17002595号-1 )
蒙公网安备 15010402000325号 腾讯云安全认证

GMT+8, 2019-7-17 00:06, 107.23.37.199 , Processed in 0.102543 second(s), 33 queries .

Powered by Discuz! X3.4 © 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表